Author Topic: Cannot get properly lubed bullets  (Read 194 times)

0 Members and 1 Guest are viewing this topic.

megasupermagnum

  • Posts: 1
    • View Profile
Cannot get properly lubed bullets
« on: April 10, 2019, 02:02:29 am »
I have had this star sizer for about 4 months, which I bought used. The guy I bought it from is an active member of the Castboolits forum, and said it works fine. I have yet to have it work at all. This thing will not fully fill a lube groove! I'll try and describe all that I have tried so far.

First of all, I have tried two dies, and two bullets, no change with either. Both are properly plugged, and the one row (one lube groove) I left open, is not clogged. I originally received this press with the air cylinder for lube feed. I also have the heated base for this. My compressor goes up to 95 PSI, and that's what I ran the cylinder at. I've tried lower pressure, but it only gets worse. It is possible to turn the heater up until the lube flows properly, but then I run into two other problems. The lube runs out all over the nose of the bullet, plus half falls out of the lube groove when it drops out of the die. The lube is nearly liquid before it will flow fully into the lube groove. When adjusting the heater, I am making small changes, and waiting a good 20 minutes for everything to equalize. This whole time, I have been messing with the punch as well. I can measure the die, and get the lube groove perfectly centered in the open row of holes. Even then, I've been messing with the punch, with no change. I mean NO change, until you cover a driving band, and at that point it wont fill the lube groove at all. One saturday I must have wasted 3 hours trying the punch about 1/16 of a turn at a time. I am 100% sure it has nothing to do with my punch adjustment.

I have tried two different lubes with no luck, one I believe was Magma lube, the other is what I want to use, Canaruba Red. I am fully stroking the press. I've messed around with double stroking, and I've tried holding it down for a few seconds. Running bullets through the press two times does work, but what a PITA. Before this, I was sizing and lube on an old Lyman 450, which does work fine. In the winter I need a little heat with canaruba red, but it doesn't take hardly anything at all to fully fill lube groves.

My air cylinder does work as it is supposed to, and does not leak. I eventually decided to try the manual lube setup. I had most of the parts, but couldn't find the screw. Either I didn't get it with, or I lost it. I found a 5/8 fine thread bolt, and a spacer, and tried it. It actually seemed to work. It took a few weeks, but I wasn't getting clear info on the screw to make my own, so I finally paid Magma for the real thing. So now I have a complete manual lube system, screw, spring assembly, and seal. While initially it worked, I came to realize that what I was feeling was the spring bottoming out, and then adding additional pressure to that. So I can make this press work, for about 3 bullets at a time. With only the spring tension, this press still will not fill the lube groove. Both the spring and air cylinder are not strong enough! :o

At this point I'm at a complete loss. It seems to me that the lube system isn't strong enough. Magma has not been a help, and the guy almost seems insulted that I insist that their design doesn't work. I've invested too much money and WAY too much time into this, and it's no better than day one. I could not use the spring, and just lube 2-3 bullets at a time before adding lube pressure, same as I do the Lyman. It would still be marginally faster than the Lyman, plus I like the bonus of nose first sizing. It seems odd to me that so many people claim that theirs works with heater at 100 degrees, and air pressure (with air feed) as low as 30 PSI. What else could I be missing? The air cylinder I have is the one sold by Magma. Has anyone tried a stronger spring on the manual lube system? Changing to a different lube is the last thing I want to do, but at this point I'm willing to try anything. I've wasted 4 months of my life, and ruined thousands of good bullets.

varmintpopper

  • Active Members
  • ***
  • Posts: 237
    • View Profile
Re: Cannot get properly lubed bullets
« Reply #1 on: July 30, 2019, 12:23:13 am »
megasupermagnum

You Prob. know this but the "high pressure" to the sizing die is supplied by Pump plunger piston (S124)  and not the reservoir spring (S129), the res. spring only supplies lube to the
piston and cylinder located in the base of the unit. The piston must make a full stroke to supply lube to the Die. The only adjustments for this is the bolt (S114).
Take a look in this area and make sure that the piston (S124) is being pushed all the way out by spring (S125) with the operating  handle all the way up. if not, the piston could be binding
in the cylinder.
Hoping You find the prob. soon, These really are great little machines.


Good Shooting

Lindy

 

anything